Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Incompatibility with Swift 5.1.x

Hi there,

After exporting the project as a xcode project, the compilation process stops with this error:

module compiled with Swift 5.0 cannot be imported by the Swift 5.1.3 compiler: ../CodeaProject/Speakeasy/Frameworks/RuntimeKit.framework/Modules/RuntimeKit.swiftmodule/x86_64.swiftmodule

My computer setup:

xcode 11.3.1

iOS Deployment Target:
Tested each From 8.0 to 13.1

Comments

  • SimeonSimeon Admin Mod
    Posts: 5,420

    @jfoc2019 that's odd, I recently updated the Codea Xcode libraries so that they are built with the latest Swift. Are you using version 3.0.1?

    Are you able to check the libversion file in your exported project? It should have the version 3.0.1 in it. If it doesn't, you can modify it, delete the downloaded frameworks and re-build to ensure Xcode downloads the latest frameworks.

  • Posts: 13

    Hi,

    I have the same problem. I deleted the frameworks but the error appears again.

    Are there newer frameworks then 3.0.1 to download?

    Greetings Dirk

  • Posts: 5

    I had the same issue and I think I've found a workaround, check out the comments on the following thread:

    https://codea.io/talk/discussion/10449/incompatibility-xcode-11-4-swift-5-1-3-cannot-be-imported-by-the-swift-5-2-compiler

  • Posts: 13

    @Denis: Thanks für the hint. It works also for me. To delete all frameworks works not for me.

Sign In or Register to comment.