Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Codea 3.3.3 (279)

dave1707dave1707 Mod
in Bugs Posts: 9,423

@Simeon Heres something I ran across, disappearing and reappearing code.

Create a new project and insert the below line in setup.
Delete all the other code except the setup function.
Run the code then exit back to the editor
The tab xxx will eventually show and you’ll see the below line of code disappear and the code you deleted reappear.

    saveProjectTab("xxx","--qwertyuiop")

Comments

  • Posts: 194

    Fwiw, I think I’ve also seen something like this occur a few times. I don’t think it’s an isolated issue.

  • SimeonSimeon Admin Mod
    Posts: 5,699

    Thanks for the clear reproduction steps. Will try to isolate

  • Posts: 1,278

    @dave1707 omg you might have just found out how to reproduce the bug that's been reverting my files

  • Posts: 171

    @dave1707 i wonder if saving before running would still revert

  • dave1707dave1707 Mod
    Posts: 9,423

    @Simeon @skar Saving the code before running it doesn’t cause the problem. Doing the “Save and Run” option doesn’t cause the code to disappear, but the new tab won’t show up until you exit the project and go back in.

  • SimeonSimeon Admin Mod
    Posts: 5,699

    @UberGoober do you tend to use the saveProjectTab function when the reverts happen?

  • Posts: 2,356
    @Simeon @dave1707 - I noticed this before when I reported the problem with commented out text when writing with saveProjectTab(). First time run tab not visible until reload/rerun.
  • SimeonSimeon Admin Mod
    Posts: 5,699

    @dave1707 hmm your steps do not work for me (the code does not revert, but the "xxx" tab also does not appear). But it gives me an idea on how to correct the problem in the next build

  • SimeonSimeon Admin Mod
    Posts: 5,699

    The next build should address this, hopefully

  • Posts: 1,278

    @Simeon it’s hard to say for certain, but several of my projects write to tabs.

  • SimeonSimeon Admin Mod
    Posts: 5,699

    @UberGoober please keep me updated on your experiences once build 280 shows up

Sign In or Register to comment.