Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Software

edited September 2012 in General Posts: 266

How do i make my app work in iOS version less than iOS 5?
I just made my first app and it works on my iPad 2 as I have the latest iOS on there?
My mom's old iPad (1) is on iOS 4.3 and can't download the app. I don't want to update her iPad because it has lots of sensitive information and wouldn't want to risk losing it. Also, iOS 5 has made the original iPad laggy. Please help, as i am really new to Xcode

Tagged:

Comments

  • JohnJohn Admin Mod
    Posts: 587

    Sorry, Codea is iOS 5 only.

  • Update the iPad 1!

  • .@John @wrmichael sorry I didn't clarify. I didn't mean Codea. I meant an app that I created that's already on the App Store (http://trdd.us/gravitydrop) I know I have to tweak something in the Codea Runtime I just dont know what

  • edited September 2012 Posts: 580

    John or Simeon, please correct me if I'm wrong, but it seems to me that if Codea only works on iOS 5.0+ then so would the runtime...

  • SimeonSimeon Admin Mod
    Posts: 5,054

    The runtime is using some iOS 5.x specific features, namely video recording and advanced font metrics.

    I suspect if you exclude those components you could get it running on iOS 4.x by setting the deployment target.

    It might not actually be that hard, I'll have to explore it — perhaps by including some #ifdefs in the runtime.

Sign In or Register to comment.