Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Editor Bug

edited August 2013 in General Posts: 6

The Codea editor always gets lost after tapping in from just running or initially opening the project. If I delete or add text it's adding or deleting in the wrong place and it moves the character I want to delete to the left. The only way I have found to fix this is to do an undo right after tapping in. The problem with that is that it takes a ling time. Editing becomes a tedious chore. Now I know that I can now use the new air code feature, but one thing I like about Codea is that I can code ON the iPad. Can we get this fixed?

Tagged:

Comments

  • IgnatzIgnatz Mod
    Posts: 5,396

    Is it because you have a very long line that was wrapped itself? If so, break into two lines by pressing enter somewhere(Codea ignores spaces and line feeds) and the problem should go awat

  • SimeonSimeon Admin Mod
    Posts: 5,054

    @Twpster can you give me a short bit of example code that reproduces your editor problem? I will fix it.

  • Posts: 372

    i get that sometimes too, but i feel that the ipad is overloaded. whenever i get this issue of cursor deleting things to the left there are at least 15 to 20 apps open in the background. closing all of them from the task manager solves the problem.

  • Posts: 6

    @Simeon thanks for the quick response. @Saurabh I think you are on to something. I restarted my iPad and the editor began working normally again. @Ignatz it doesn't seem to be related to too long of a line. I will do further research and keep you posted. Thanks for the responses!

Sign In or Register to comment.