Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Dropbox sync - lost images!

edited April 2014 in Bugs Posts: 725

Recently I have lost around 600 images from Codea while using Dropbox.

The method I use for adding images to Codea is to draw them in inkpad, select copy drawing, switch to Codea, select the sprite picker, click add from pasteboard, enter a name and use.

All worked well and allows me to do this offline without the need to such (I suspect codea copies the images to a local location then synchs manually when the sync button is pressed)

However I hadn't done this in a long while

I updated to Codea v2 and everything was still fine. I then thought I hadn't sync'd Dropbox in a while so I better do that. 600 odd items later access to all these images have disappeared (though some old previously sync'd files are still accessible)

Is there a simple way to restore this? I can go back and manually add all 600 images again (in reality I won't as they were just in development assets) but that's a right pain.

Finally, once you add an asset from pasteboard the option to sync disappears so if you want to ensure your Dropbox assets are kept up to date, you need to reopen the sprite picker and press sync. @Simeon is this intentional?

Has anyone else had these issues? Is this a crazy way to integrate custom assets from inkpad into codea?

Comments

  • Posts: 62

    I have not had this issue. The only way to get the pictures back is manually as far as I know, sadly.

  • Posts: 1,595

    I had this issue but when I pressed sync all 180 of my images popped up in about half a second, I think it's just failing to recognise it's existence.

  • SimeonSimeon Admin Mod
    Posts: 4,932

    @West did you have any luck recovering your images? Are they accessible via the Dropbox app, or are you able to see them in Codea with iExplorer?

  • Posts: 725

    No luck so far @Simeon - can't see them in the Dropbox app. Don't have access to iExplorer at them moment - will check tonight

  • Posts: 725

    OK I managed to recreate the issue (unintentionally so I lost a bunch more images). the root of the issue is pressing outside the sprite selector before it is finished synching. This appears to abort the sync at whatever stage it is at. Reopening the sprite selector and pressing sync, says it is syncing the images but apprears to do so very fast but the images aren't synced and are lost

Sign In or Register to comment.