Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Codea Community

edited April 2015 in Code Sharing Posts: 1,141

Hi All,

Had this problem with CC and posted on the old thread, now getting pretty huge. So I thought I'd repost and include the installation code for two reasons:

  1. Put it at the head of the thread so it can be easily found.
  2. I want to check that this is the latest installer.

Why? Because I had a problem getting back into CC, see previous post below. Anyone any ideas how I can progress?

p.s. I got this installer from the wiki.

Could we have a direct link to the CCwiki on the Codea main page - rather than having to search for it in discussions?

function setup()
    http.request("http://codea.io/cc/alpha/installer.php",
        function(d) loadstring(d)() end,
        function(e) print(e) end
    )
end

NOTE - the above code has now been edited to reflect Jordans post below

i.e. link is no longer "http://twolivesleft.com/Codea/CC/alpha/installer.php"

Bri_G ;)

NOTE 2 - I have also copied @toffer's amendments and comments here. This now works on my iPad 2:


@TheMcSebi @Brig_G - I've updated the installer to link the last version. I can't patch the sources myself but with the following, that should work. Re-install from the installer and apply this changes : Main tab, lines 139-141 comment = string.gsub(comment,"%*","\n*") comment = string.gsub(comment,"%+","\n+") comment = string.gsub(comment,"%-","\n-") HelperFunctions tab, line146 for part, pos in string.gmatch(str, pat) do'

Thanks,

Bri_G

:D

Comments

  • IgnatzIgnatz Mod
    Posts: 5,396

    @Briarfox may have a comment on this

  • edited November 2014 Posts: 371

    replace your link with http://codea.io/cc/alpha/installer.php"


    EDIT: Seems like codea community is broken :(

  • edited November 2014 Posts: 1,141

    Hi @Jordan,

    I've replaced the link in the above code and commented on it - so that the code sample at the top of the page is relevant.

    Although, with reference to your own edit - do we assume that the CC is down ?

    Anyone know? and if so why?

    Bri_G

    :D

  • Posts: 371

    @Bri_G it seems that CC was moved from server to server, first there was one hosted by (I think) Briarfox, then Simeon hosted it on twolivesleft, now it is on Codea.io, but the source code is still outdated, referring to the twolivesleft link

  • BriarfoxBriarfox Mod
    edited November 2014 Posts: 1,542

    @Bri_G I'll take a look at it. I had updated CC for Codea.io

    If you recall your username and password you can use them to get into your account. If not I'll need to to create a new user with a password so I can copy the hash over to your old account.

    Sorry I've been MIA on this, been busy with the family.

    This version should work. http://codea.io/cc/alpha/index.php?v=1725

  • Posts: 1,141

    Hi @Briarfox,

    Thanks for the link, tried it out but the following error resulted:

    'error: [string "-- _CCMenu..."]: 2109: Project tab "(null)" not found'

    Hope that makes sense to you, its in the Community.readProjectInfo function under 'Restored'. The line reads:

    tab = readProjectTab(lmain)

    Don't knock yourself out resolving this for me, I just wanted to restore my system including CC after the iOS 8 install. I like to see what other users have been coding.

    Thanks,

    Bri_G

    :D

  • BriarfoxBriarfox Mod
    Posts: 1,542

    @Bri_G have you tried removing CC and pulling it from the above link?

  • Posts: 1,141

    Hi @Briarfox,

    In short - yup!

    Got the error in my post above. My pad has been purged of all personal data etc when I installed 8.0 and later 8.11. Don't know if there was any impact from that.

    Thanks,

    Bri_G

    :D

  • I've seen lots of references to Codea Community, and the backup feature sounds really useful, so thought today was a good day to try and get it running. However I'm falling at the first hurdle. When I open the latest link (to 1.1.1.3 in the thread above) on my ipad I don't get the sidebar in order to see the icon to copy the code. Am I missing something obvious? I tried using safari to request the desktop site but that just returned what looks like a mobile optimised site, without the crucial sidebar. Can anyone help?

  • Posts: 1,976

    @epicurus101 If you open it in Codea's web browser, is the sidebar not there?

  • Do you mean going through the Codea Talk link on the menu screen? If so, no the sidebar isn't there when I click the link. If there's some other browser function I'm missing out on, let me know!

  • edited January 2015 Posts: 1,976

    @epicurus101 Weird, it works fine for me (iPad Air 1, iOS 8.0.0) What iOS version are you on, and what iPad version? That might help.

  • IPad Air 1, iOS 8.1.1

    Does it also work if you try direct through Safari?

  • Posts: 1,976

    @epicurus101 It works for me in Safari. I don't know why it's not working for you.

  • D'oh. It was a stupid mistake. I just needed to turn landscape and there it was!

  • edited January 2015 Posts: 2,020

    Hello, I'm trying to use Codea Community for the first time. I managed to install the code using the installer at the top of this page. When I run it though, attempting to register a username and password results in this error:

    ERROR: Failed to connect: Access denied for user 'ccadmin.twolives'@'localhost' (using password: YES)

    (I don't know why it thinks I'm trying to log in as cc admin. I was trying to register yojimbo2000 as my username)

  • edited January 2015 Posts: 2,020

    Ok, I got it to work and register my username by replacing the references in the code to twolivesleft.com/Codea with Codea.io

    Edit... Wow, cc is awesome!

  • Posts: 289

    i submit username and password: Failed ... 404. BTW, when download logo:Failed, attempted call a nil value. maybe because of my internet

  • Posts: 25

    Is codea community still being worked on?

    Im getting an error in line 136: "invalid escape sequence near ""

  • Posts: 1,141

    Hi TheMcSebi,

    Tried several time over the last few months without success. Not sure what the problem is - tried the corrected version from @briarfox but no success. Struggling to get enough time on Codea at the moment so tend to prioritise what I pursue. Recently been checking out all my code in 2.3 and looking at the new features.

    I would contact @briarfox if I were you, he is the one with his finger on that pulse.

    Bri_G

    :(

  • toffertoffer Mod
    Posts: 151

    @TheMcSebi @Brig_G - I've updated the installer to link the last version. I can't patch the sources myself but with the following, that should work.
    Re-install from the installer and apply this changes :

    Main tab, lines 139-141

    comment = string.gsub(comment,"%*","\n*")
    comment = string.gsub(comment,"%+","\n+")
    comment = string.gsub(comment,"%-","\n-")
    

    HelperFunctions tab, line146

    for part, pos in string.gmatch(str, pat) do
    
  • Posts: 355

    hello guys. finally back.

    a cuestion: CC is having problems with the login ?
    i use IOS 8.2

  • Posts: 2,020

    Does the code you have still refer to the old twolivesleft website (instead of codea.io)? See my post above

  • toffertoffer Mod
    edited April 2015 Posts: 151

    @Luismi - If you encounter following error at connection
    error: [string "--Community..."]:89: attempt to call a nil value
    the version used is not the right. Give a try with the one pointed in this thread (beta 1.1.1.3) plus the patch, Ivre no issue with it from IOS 8.2.
    @yojimbo2000 - nop, with the one reference is this thread (codea.io) for the last Codea version (lua 5.3)

  • edited April 2015 Posts: 355

    @toffer this is my problem when I try to login to CC :

    Logged as Luismi - perfect

    Request failed : unnaceptable (406) .
    And then say this : unable to check pending unauthorized (401)

    @yojimbo2000 yea, I am using the new link codea.io

  • toffertoffer Mod
    Posts: 151

    @Luismi - very strange, it seem the connection end point is good but not the others. I've checked and there is no pending locked for your account. Can you pm me the entire code of cc you use, please.

  • edited April 2015 Posts: 355

    @toffer . Yea this is weird , because last night , I put the installer code in my other IPAD (ipad1 iOS 5.1.1) and no problem with the installation and the login, all good.

    The problem is in the iPad air2 (ios8.2)

  • Posts: 25

    @toffer for me everything works fine after i've applied these changes. Thank you :)

  • Posts: 25

    I am getting issues running CC.

    It fails parsing at line 139

        comment = string.gsub(comment,"%*","\n\*")
    

    With the message

    Invalid escape sequence near '" [sic]

    If I comment out this line and the 2 following which are similar, I get an error at runtime, before anything interesting displays.

    Any thoughts anyone? I am using Codea 2.3 (45) on an iPad 2, under iOS 7.1.1

  • edited April 2015 Posts: 2,020

    Look at the post up the thread http://codea.io/talk/discussion/comment/59169/#Comment_59169

    You need to take out one of the \

  • Posts: 1,141

    Hi @toffer,

    Thanks for the update - modified as you suggested and the app now works. Will modify my original post accordingly. Had to set up a new account as couldn't remember my password.

    Thanks again,

    Bri_G

    :D

  • Posts: 25

    Thx @yojimbo2000 . It works much better now but when I try to download a project Codea crashes.

    Side note @Simeon, @ignatz, the GUI is amazing, I tried going through the code to find out how this is done, but I couldnt find it. I thought the codea script was setting up a webserver and all the GUI is done in the webclient built in codea, but I couldn't find any html or socket code. Where is the code that does the GUI?

  • IgnatzIgnatz Mod
    Posts: 5,396

    @joelhoro - the code isn't mine, the guy you should ask is @toffer, he did an amazing job

  • BriarfoxBriarfox Mod
    edited April 2015 Posts: 1,542

    Hey guys sorry that I have been away been busy with kids and other projects. It's been ages since I looked over the code. I'll get it up on github so it can be community maintained and get @toffer and @ignatz the CodeaCommunity login info to update the download.

    @toffer feel free to take over the CodeaCommunity account (reset the password). I'll give you access to the github page. Maybe you'd like to add the server project as well?

Sign In or Register to comment.