Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Xcode conversion error

in Bugs Posts: 3

I'm made a game and downloaded it onto Xcode but the program can't build.
This is the error that pops up: Command /bin/sh failed with exit code 1

Can someone please help me!!!!!!!!!!!!!!!!!!

Comments

  • @Scott_ don't worry, we already notified John, one of the makers of Codea, he's working on it, at least I hope

  • ok thanks @CamelCoder

  • Posts: 19

    New version of Xcode V9.1 gives me an error message below while building Codea codes which were successfully built with previous version of Xcode.
    "Code sign error with edit code 1 - command/usr/bin/codesign failed"
    How can I avoid such error?

  • Posts: 19

    Supplement to my previous comment on Nov 20.
    The error message I got is the same as Scoot got last December.
    But at that time, I didn't have such error message. Codea worked fine.
    This issue emerges after upgrading Xcode to V9.1 to work with iOS 11 this November.
    Meantime, I have checked various Codea codes including demo programs in Codea package, however they resulted in the same error.
    I didn’t know how Scot's issue was resolved, it seem that this is a new problem wth Xcode9.1.

  • Posts: 19

    Somehow I could solve this problem:
    Solution; 1) clear build folder for the project (by cmd-opt-shift-k) and 2) reboot Mac.
    It looks that every project built after the Xcode version up has problem in its build folder which requires cleaning.
    Then I can build them successfully.

Sign In or Register to comment.