Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Craft Projects don't run on my iPad 3 running iOS 9

Am I just SOL with an iPad this old?

Error message is the same every project:

[string "-- Craft Scenes..."]:28: bitset to_ulong overflow error
stack traceback:
    [C]: in method 'draw'
    [string "-- Craft Scenes..."]:28: in function 'draw'

It seems like I might be able to manually fix it if it's just that one line....

Tagged:

Comments

  • em2em2
    Posts: 167

    "Overflow"? That may be a hardware issue.

  • Posts: 553

    Maybe they just didn't update the specs on the App Store. I'm running 9.3.5 and it says it will run on 9.3 or later...

  • em2em2
    edited October 4 Posts: 167

    That may be a hardware issue.

    Hardware, not iOS version (e.g. iPad model). On your comment about the description, that may still be true for most features, not all.

  • edited October 4 Posts: 553

    @em2 you're right, and I unadvisedly left out the whole specs section regarding this, which reads

    Compatibility: requires iOS 9.3 or later. Compatible with iPad.

    I don't have any kind of animus though, about it, it's old hardware, I get it. They could helpfully update the Compatibility section, I think, is all.

    BTW all the old sample projects run fine, including the 3D ones, which I mention just for the sake of complete information.

  • em2em2
    Posts: 167

    It may be a bug, so I'll be quoting you in the Codea Craft bugs thread.

  • JohnJohn Admin Mod
    Posts: 456
    I’ll look into this and see what’s happening. If iOS lets you run it then it should work
  • SimeonSimeon Admin Mod
    Posts: 4,459

    @UberGoober looks like a bug with 32 bit CPUs. I'm guessing this should be possible to fix on our end and is due to a lack of us testing on real hardware. Sorry about this!

  • Posts: 553

    No sorry, I'm elated to hear it could be fixed at all! Besides I was in the middle of a 2D project and I didn't need the distraction anyway. :)

  • Posts: 147

    @Simeon Sorry to bring a month old post back up, but I'd just like to inform you that I am also having the same issue. I have an Ipad Mini 1, version 9.3.5 and I'm getting the same error whenever I run any code that uses Craft.

  • em2em2
    Posts: 167

    @Kolosso what craft version are you on? Have you read the beta threads?

  • Posts: 147

    @em2 no. What beta threads? I haven't been very active on the forums lately.

  • SimeonSimeon Admin Mod
    Posts: 4,459

    @Kolosso a fix for this is still "In Review" with Apple for over a week now. I contacted them about why this is taking so long but they are yet to get back to me.

  • Posts: 147

    Thanks @Simeon. I Can wait as long as it takes. I'm just glad I'll be able to try out Craft! :)

  • SimeonSimeon Admin Mod
    Posts: 4,459

    @Kolosso it should be out now. 2.5.1 should run Craft projects on 32 bit devices.

  • Posts: 147

    @Simeon It worked! Thank-you so much!

Sign In or Register to comment.