Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Augmented reality bugs

in Bugs Posts: 5

Hello, I seem to be having problems with the AR portion of codea. I currently have an IPad mini 2 that previously had no problems with executing the AR sample programs with no problem in the past. Now neither sample AR program can run due to some new incompatibility. I was wondering if there was a new change in Codea or if it was apple that caused it. Thank you for any help you can provide.

Comments

  • dave1707dave1707 Mod
    Posts: 7,155

    @CodeaC0D3R These are the devices that can run AR.

    According to Apple’s official ARKit resources for developers, ARKit requires high-performance hardware—apps built on it run on the Apple A9 and A10 processors.

    The following devices use these processors:

    iPhone SE
    iPhone 6s
    iPhone 6s Plus
    iPhone 7
    iPhone 7 Plus
    9.7-inch iPad (2017 model)
    10.5-inch iPad Pro
    12.9-inch iPad Pro (2017 model)
    9.7-inch iPad Pro (2016 model)
    12.9-inch iPad Pro (2016 model)

  • Looks like apple dropped support for my device then. Thank you for your help dave, you have a good day.
  • dave1707dave1707 Mod
    Posts: 7,155

    @CodeaC0D3R Your iPad mini 2 and my iPad Air have the same processor types, A7. If I try the AR code now, I get a screen message saying AR Not Supported and nothing runs. AR support was always A9 or higher, so I’m not sure how the AR code worked on your iPad mini 2. Unless the code ran but the AR part didn’t work. I don’t remember if that happened on my iPad Air when I first tried the AR code because after that I always ran it on my iPad Pro, A9 processor. .

  • That’s the interesting thing, even though I have an A7 processor, the code was able to ran and the AR part worked like a charm. It wasn’t until I received-what was at the time-recent updates that I had problems. I looked through the code of AR and Voxel Editor Ar to see if there were any changes to either of them; there was not any noticeable change in AR, it didn’t show what part of the code wasn’t out, the Voxel Editor on the hand tells a different story. Here are some photos of faulty output.

  • I’ll give a crack at this now and see if I can solve the mystery before I turn in for tonight, especially since I have no coffee. Thank you for helping me out, and have a good night.

  • edited October 24 Posts: 5

    I found that when it comes to the voxel AR program, right now it doesn’t do anything. Well, if I try using any grids the whole things freezes faster than the Flash’s brain when he puts ice cream to the roof of his mouth. Then I have give the executed program a soft reboot. The other voxel game samples work fine, which is fascinating.

Sign In or Register to comment.