Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

3D object files with a material file that includes a texture.

in Bugs Posts: 59

Textures aren't being loaded in my project if the color is specified in the materials file. The object will show up correctly in the object viewer popup with the textures, but when run in the project the textures are missing.

If my object.mtl file has:

newmtl wire_1
Kd 0.0039 0.0078 0.0018
map_Kd obj1Diff.png

This will cause the object viewer popup to show correctly but not when the project is run. The texture will be missing and a single color will be shown on the object. No error will occur.

However, when I comment out the color it will work in both the object viewer and in the project code.

newmtl wire_1
#Kd 0.0039 0.0078 0.0018
map_Kd obj1Diff.png

The materials file is auto generated, so it is a little difficult to comment it out each time I make an edit.

If you have the time, could you please look in to it. Thanks!

Comments

  • SimeonSimeon Admin Mod
    Posts: 5,054

    @exomut thank you for finding this. Looks like Codea is ignoring the texture map if a diffuse value is specified, where the object popup is ignoring the diffuse value if a material is specified... I'll log it and see what can be done

  • Posts: 59

    @Simeon Thanks for logging it! I need to use both diffuse value and texture map to allow for tinting of textures if possible.

Sign In or Register to comment.