Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Runtimekit, Xcode 11, Swift 5.1

odoodo
edited October 2 in Bugs Posts: 13

Hello,
with the latest Xcode 11.0 I get this error when I try to compile a Codea Project:

module compiled with Swift 5.0 cannot be imported by the Swift 5.1 compiler

complaining about this module:
Frameworks/RuntimeKit.framework/Modules/RuntimeKit.swiftmodule/x86_64.swiftmodule

Maybe you would have to compile the runtime with the latest XCode?

As a workaround I will try to install an older Xcode version on my notebook.

Comments

  • odoodo
    Posts: 13

    @twoem , as a workaround, use an older XCode version.
    You can install multiple XCode versions in your Macs apps folder (remember to give each version a unique name) and select your current version with xcode-select command line tool.

Sign In or Register to comment.