Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

How to trasfear codea code to xcode because i want to upload it on the ipad appstore

edited July 2012 in General Posts: 69

Pleas i want a fast reply



  • Posts: 15

    You have to download a thing called the Codea Runtime Library. That's about all I know, because I'm eleven years old.

  • And me iam 12 years old

  • Download iExployer
    Connect the iPad to you mac.
    After launching look for Codea in left panel.
    Drag you fileName.codea to the desktop.

  • Can I copy the code to my email and past it to the Xcode with out I explore

  • Posts: 563

    There is a tutorial on how to do this here:

    No need for iExplorer or the runtime anymore, there is an export to Xcode function in Codea.

  • Posts: 1,255

    You don't need to worry about the runtime anymore. With version 1.5, you just export.

  • Posts: 119

    @reefwing , I ju updde my codea to try the new export function. I am having some apple mach-O linker errors. (e.g. "SSLHandshake", "SSLCreateContext"). Did I miss something out from your tutorial?


  • Posts: 893

    @zapaper likewise. I tried last night and got 14 mach-o errors

  • edited July 2013 Posts: 563

    @zapaper and @West - version 1.5.3 introduced a bug. @Simeon is on the case. In the meantime:

    In Xcode, open your exported project:

    • Go to your project settings (click on the blueprint icon in the Project Navigator)
    • Select the "Build Phases" tab
    • Expand "Link Binary With Libraries"
    • Click the + button at the bottom of the list
    • Choose "Security.framework" and click add

    Codea 1.5.4 will fix this bug in the exported project template. But you will have to use this workaround for now.

  • Posts: 893

    @Reefwing - awesome - worked - thanks for the help.

  • Posts: 1,976

    Just press and hold on your Codea project, and select "Export." Am I the only one that noticed that?

  • BriarfoxBriarfox Mod
    Posts: 1,542

    @skythecoder there is a bug in 1.5.3 that doesn't export correctly. Fix is above.

  • edited July 2013 Posts: 1,976

    Oh, derp...

  • Posts: 119

    That fixed it for me :)

Sign In or Register to comment.