Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Projects Assets with the Same Name

in Bugs Posts: 59

I normally use a image for a background in my projects. I always add it directly to the project and name it “background”. I noticed that if I open one project that uses an image located in the project folder and run the project, and then switch to another project that uses a different image, but named the same “background” and run the project, the second project will use the image from the first project.

The easiest solution to this, is to fully close Codea and open the second project. It isn’t that big of a problem. I just thought you should know.

Comments

  • dave1707dave1707 Mod
    Posts: 7,810

    @exomut There are other issues that also require the user to close the project or Codea for them to take affect. One is when a new tab is created within the program. There are others that I've run into but I don't remember at the moment. You just get used to it.

  • SimeonSimeon Admin Mod
    Posts: 5,054

    @exomut thanks for reporting this, sounds like an issue with the asset cache

    @dave1707 every time you make a new tab you have to close and open Codea?

  • dave1707dave1707 Mod
    Posts: 7,810

    @Simeon My mistake. I just tried it and it's OK. There is something else that requires Codea to close for it to work. I can't remember what it is and I'll post it the next time I run into it.

  • SimeonSimeon Admin Mod
    Posts: 5,054

    @exomut this bug will be fixed in the next version

    @dave1707 no problem

  • Posts: 410
    @dave1707 maybe it was when including a shade shader?
  • edited May 22 Posts: 1,326
    @dave1707 - are you thinking about the Dropbox sync? Also, I think file transfer into Codea documents folder needs restart - I think Codea only keeps file data from when it runs initially. Possibly updates after it writes it's own data to file.
  • dave1707dave1707 Mod
    Posts: 7,810

    @Simeon I was correct the first time, there is a problem with creating/reading tabs. I found my original code that was giving me the problem and below is a stripped down version that causes the error. When I run the below code, it creates the tab test, but gives me the error message below when it tries to read it. If I close the project and run it again, I get the same error. I have to close Codea and open the project before it works. Also, after it works, if I delete the tab and run the code, it works fine. It must save the tab name even though it was deleted.

    Main:6: Project tab "test" not found
    stack traceback:
        [C]: in function 'readProjectTab'
        Main:6: in function 'setup'
    
    function setup()
        str="\n--qwertyuiopasdfghjklzxcvbnm"
        saveProjectTab("test",str)
        a=readProjectTab("test") 
        print(a)   
    end
    
  • Posts: 59

    @Simeon thanks addressing the issue. Like always, keep up the great work!

    @dave1707 I have experienced a few bugs that force a restart of Codea. Even one in Shade that forced a restart of my iPad. I wish I remember what caused it so I can report it. I can’t even begin to imagine how big and complex the code base for Codea and Shade are. I can handle a few bugs. I am just so excited to program for the iPad with out having to connect to a Mac for every little change I make to my app.

Sign In or Register to comment.