Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

new xcode export missing frameworks?

edited October 2021 in Bugs Posts: 323

hey i just started trying to move a project into xcode and i immediately have problems with missing frameworks
i don't fully understand but i think these are supposed to be included with the export from codea?

Showing All Messages
There is no XCFramework found at '/.../Frameworks/RuntimeKit.xcframework'.
There is no XCFramework found at '/.../Frameworks/CraftKit.xcframework'.
There is no XCFramework found at '/.../Frameworks/ToolKit.xcframework'.

Anyone have any ideas?


  • Posts: 323

    yeah i just tried a blank new project and it's the same problem,

    codea - 3.4.4 (303)
    ipad - 15.0.1

  • Posts: 2,728

    I tried the latest XCode recently and couldn’t get anything to work. Long time since I used it - thought it was just me.

  • Posts: 323

    i don’t mean to be ungrateful but are we going to get a fix here? Codea is my favorite engine, i want to see it at its best at all times, please open donations if it may help improve development speed

  • I’m building my current project on the grounds to at I can get it into the App Store once I’m done.

    So +Xcode export fix(though it will be some time before I need it complete)
  • Posts: 2,728

    @skar @Simeon - thanks for that, I have been playing with the menu bar to try to get those frameworks in, opened up a new door for me now although it's a bit slow on my mac. Would it be useful to have another topic at the top of the forum to support Xcode and similar issues ?

  • Posts: 323

    yes i think the whole appeal to codea is eventually moving the code to xcode to see how you can publish it

Sign In or Register to comment.