Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

WebRepo 2.0 - Easy access to projects from the Codea community



  • edited November 2021 Posts: 1,817

    DOUBLE D’OH!!!

    I was running it in web repo 1.0, and it loaded the interface but it didn’t work…

    It works just dandy I’m 2.0!

    Sorry if I gave you a fright!

  • Posts: 421
    Ah, I'm glad to hear it!
  • Posts: 2,724

    @Steppers - had a problem with this. Downloaded and installed. Ran in Portrait and alert came up for an update. Accepted update and during/after that it crashed. Found two versions on the project page both hung up when run.

    Also at one stage I selected games but couldn’t select other options from the category links at the bottom - locked into Games.

  • edited November 2021 Posts: 421

    @Bri_G I think there’s an issue at the moment when it updates requiring you to return to the project browser first. What was the project called when you installed it from the zip? It should just be ‘WebRepo’

    As for the locking into games I think that happens if you change tab before the projects are loaded. I’m aware of this one.

  • Posts: 2,724

    @Steppers - when I first installed it it came up with 'WebRepo 1' as the suggested name as I had WebRepo already. I changed it to WebRepo2 but I also had that (apparently) finally installing it as WebRepo2b . From there it suggested the update which crashed my pad.

  • Posts: 421

    @Bri_G Thanks, that should be fixed in 2.0RC4 now and should update fine in future regardless what you name the project (i.e. Updates following RC4)

  • Posts: 421

    @UberGoober Aspect ratios also fixed now, though it can crop a lot of the image out.

  • Posts: 2,724

    @Steppers - exported and removed existing WebRepos and loaded latest one up . Installed, closed Codea and re-opened Codea, ran the update and all seems well at the mo. Thanks.

  • Posts: 1,817

    Trying to exit the program with the little red x has been crashing Codea.

  • Posts: 421
    @Bri_G Glad to hear it.

    @UberGoober I can't say I've seen that one before... it should just be calling viewer.close() after all :/ You may have to resort to swiping in from the left of the screen to close then.
  • Posts: 1,817

    In the drop-down menu for submitting an app, the list is sorted in a way that puts words that start with lowercase letters at the bottom of the list. This can make it seem like the list is missing projects — I was just confused about this myself, because I was looking for a project that I had named “dave1707 Center On Screen”, but before I figured out how the list was sorted it looked like the list was just failing to detect that project.

    I recommend ignoring capital letters when sorting projects.

  • Posts: 421
    @UberGoober Thanks for pointing that out, I'll take a look.

    If you're not already aware though, the search tab searches name, short description and authors so the author in the project name isn't entirely necessary and can bloat the name in the app listings leading to some overlap on iPhone.
  • Posts: 1,817

    I’m not sure what to do about that, because your system is good for your app’s purposes and my system is good for mine personally.

    I name things that way because I have tons and tons of projects cluttering up Codea, both mine and other people’s, and if I need to find one, it turns out that having the author’s name in the title really cuts down on search time. So I’m not about to stop naming my own projects that way.

    Your app-submission form is great but it’s not possible to change the app name on it. Enabling that would help.

  • edited November 2021 Posts: 421

    @UberGoober Oh I see. I think it could be a good idea to remove the author names temporarily then during a submission. It makes my life a little easier at least :sweat_smile:

    Fwiw, I’ve just spent the past hour or so looking into adding an additional ‘display name’ but I’ve just ended up at the conclusion that it ends up adding far too much complexity to the system. The submission form for example, pre-fills the fields if the project has been submitted before, but this wouldn’t work if the project name differs from that on the repo.

    I also attempted to append the author names automatically to projects when they’re installed but this goes against the idea that someone can easily download a project, make small changes and simply resubmit the same project with their own changes (in a new version) for the same reason as above.

    Unfortunately I think we’re stuck with the current naming convention for now.

  • Posts: 1,817

    I'll try to remember to convenient-ify before I upload. Remembering's not my strong suit, be forewarned. But I'll give 'er a go.

  • Posts: 421

    @UberGoober Thanks, I’ve added a reminder to the submission form too now.

  • edited November 2021 Posts: 2,724
    @Steppers - I thought there were system variables for project authors etc. I used them initially but got out of the habit. We should encourage authors to use them for projects added to WebRepo.

    Second thoughts - I think this was using saveProjectData() with Author and Version used as key values.
  • Posts: 421
    @Bri_G You're right from what I've seen. The values just get added to the project's Info.plist file.

    WebRepo 1.x used the plist file to obtain metadata but json is far easier to work with in an automated system in my opinion. Especially as Codea has json support built in.
  • Posts: 2,724
    @ronjeffries @dave1707 - hmmmm, would it be possible to use saveProjectData() to load a sub program that could be called to run in parallel with a Codea project? By loading and asset and calling the key?
  • Posts: 2,724
    @ronjeffries @dave1707 - hmmmm, would it be possible to use saveProjectData() to load a sub program that could be called to run in parallel with a Codea project? By loading and asset and calling the key?
  • Posts: 1,362

    in parallel? not easily. what would it do?

    i see two issues. 1, load from data, probably easy. 2, run in parallel. no real clue in that.

    git a simple example of what it might do?

  • Posts: 2,724

    @RonJeffries - just thinking it could possibly build a list of variables in use and monitor values. Probably only what we can see using but if it wrote to a log you could potentially interrogate it if Codea crashed.

  • Posts: 421

    @Bri_G Bear with me, I have an idea :wink:

  • edited November 2021 Posts: 2,724

    @Steppers - couple of things. When you run WebRepo in portrait mode the button text is duplicated and above the image so blue text on black. Secondly downloaded the web server and an error was thrown up, image below.

  • Posts: 2,724

    Here’s the photo - sorry messed up original post.

  • Posts: 421

    @Bri_G I think there are some problems with viewer.restart() following an update so your best bet is to close the project and reopen it from the project browser.

    That crash should have been fixed since 2.0RC8.

  • Posts: 1,817

    I am consistently impressed not only with your skill and speed at programming but with your ingenuity in coming up with ways to improve the Codea experience.

    Also the graphic designer in me howls in silent agony at this (image attached).

  • Posts: 1,817
    As of 3:13, 10th of Nov 2031:

    Crashed on updating.

    Started a submission, left project to check on another project, started WebRepo again and now the text fields are unresponsive. I can’t enter or edit information about the submission.

    Also tapping on the unresponsive fields repeatedly caused a crash.

    Sorry to be the bearer of irritating news. As ever, this is great work.
  • Posts: 421

    @UberGoober Does this still happen?

    @Simeon I’ve hit a limitation of Codea today, with the new (I think) asset sub-folder support I’ve just received a project submission that utilised this. Unfortunately Codea doesn’t currently have any method that I’m aware of that I can use to create sub-folders programatically to allow me to support this in WebRepo. Any chance this could be a simple addition?


  • edited December 2021 Posts: 1,817

    The field-lock seems to be gone, but I just tried to submit something and got a big long error, screenshot attached.

    I wrote rather long descriptions of the last couple things I submitted, and they don’t show up in the project info. Were they unacceptable for some reason?

  • Posts: 421

    @UberGoober I’ll look into that crash.

    That’s worrying…
    Did the ‘Upload & Submit’ button change to ‘Submitted’ at any point when you tried to submit? (not when it crashed). I can’t see any signs of an upload on Github nor AWS so something tells me it never made it beyond your device for some reason :/
    When did you submit the last couple of things & what were they called?

  • Posts: 421

    fwiw, skar managed to complete an upload 5 days ago so it’s at least working for some.

  • Posts: 421

    @UberGoober What was the project called (word for word) that you got that crash with?

  • Posts: 1,817

    CubeDeform, one word.

    I believe I wrote wordy descriptions for Ignatz Dogfight and Color Studio.

  • Posts: 421

    @UberGoober I’ve made a small update to guard against missing Info.plist files in the submitted project. That should be available to you soon.

    Can you definitely confirm the project has an Info.plist file inside (with the asset manager I believe)?

  • edited December 2021 Posts: 421
    And I assume you keep getting the same crash when submitting it? Or an error about the plist file using 2.0.2?

    Sorry for bugging you, just trying to figure out why it could even be failing where it is :/
  • Posts: 1,817

    Still crashing sorry

  • Posts: 323

    @steppers one thing about the submit form is the text entry field do not have a copy/paste pop out when tapping into them (i use apple pencil not a keyboard)

  • Posts: 323

    @steppers somehow i’ve lost the connection of my 2D lights project to the update method, now when i go to update it the form acts as if it’s a new project and all the previous info is gone

  • Posts: 421
    @skar Oh, that's odd and I'm seeing the same thing. I'll take a look.
  • Posts: 421
    @skar It should be sorted in WebRepo 2.0.3 once the GitHub action gets its act together and approves the update... Just keep an eye open for the update popup.

    There was just a small issue in the restore logic when a project has spaces in it (they're replaced with underscores on the backend).
  • Posts: 911

    @Steppers - not used this in a while - went through association with Github, but now stuck with the "A WebRepo update is available" popup on the screen, but I can't select either Yes or No

  • Posts: 421

    @West Was this after launching the old version? If so it’s probably a good idea to delete the WebRepo project and redownload 2.0 from Github.

  • Posts: 911

    @Steppers - yes that fixed it - thanks

  • Posts: 421

    Version 2.1 adds support for project subdirectories.

    Now possible due to the recent ObjC bindings allowing us to create folders directly :smile:

    Creating a folder (if it doesn’t already exist):

    local path =  asset.documents.path .. “/my_new_folder”
    local fm = objc.cls.NSFileManager:defaultManager()
    if not fm:fileExistsAtPath_isDirectory_(path, true) then
        fm:createDirectoryAtPath_withIntermediateDirectories_attributes_error_(path, true, nil, nil)
  • Posts: 298

    It’s a great app for sharing and learning!

  • Posts: 1,817

    I don’t understand the usefulness of creating subdirectories.

  • edited January 2 Posts: 421
    @UberGoober Mainly to ease asset organisation.

    Coder's asset browser has recently been updated to support creating sub-folders so this is more an update of necessity really. This way if a project is submitted that makes use of it, WebRepo doesn't just crash when installing the project.

    AirCode 2.0 is an example I used for testing. There are a lot of JavaScript files used by the web editor so it helps to use the libraries as-is without having to modify them.
  • Posts: 661

    @Steppers finally got around to trying out WebRepro. It's really a fantastic tool-well done!

    By the way, i tried to download 'Wrigglers', but it does not seem to load properly? All the others i tried seem to work.

Sign In or Register to comment.